Can I make the postal code a required field?

You need to edit two files in order to get the new “required” fields working. First file is /wp-content/plugins/speakout/includes/emailpetition.php and the second file is /wp-content/plugins/speakout/js/public.js The first file: emailpetition.php The following steps are required in order to make the field “required”. Find the following line. <label for=”dk-speakout-postcode-‘ . $petition->id . ‘”>’ . __( ‘Postal Code’, ‘speakout’ ) . ‘</label> Change this line to; <label for=”dk-speakout-postcode-‘ . $petition->id . ‘” class=”required”‘ . ‘>’ . __( ‘Postal Code’, ‘speakout’ ) . ‘</label> The second file public.js Find the following lines: if ( lastname === ” ) { $( ‘#dk-speakout-last-name-‘ + id ).addClass( ‘dk-speakout-error’ ); errors ++; } Append the following code just after this section . if ( postcode === ” ) { $( ‘#dk-speakout-postcode-‘ + id ).addClass( ‘dk-speakout-error’ ); errors ++; } So it should look like this: if ( lastname === ” ) { $( ‘#dk-speakout-last-name-‘ + id ).addClass( ‘dk-speakout-error’ ); errors ++; } if ( postcode === ” ) { $( ‘#dk-speakout-postcode-‘ + id ).addClass( ‘dk-speakout-error’ ); errors ++; } (Thanks to @altinkaya)